It is currently Thu May 13, 2021 3:08 am

Click the link below to visit the site sponsor

The Ham Radio Shop




Post new topic Reply to topic  [ 1 post ] 
 Collins KWM380 
Advanced Member

Joined: Mon Nov 28, 2011 8:57 pm
Posts: 419
Location: Co'Durham
Feedback: 5 (100%)
Reply with quote
Post Collins KWM380
Anyone familiar with the above transceiver ? Looking for a Collins man with a repair in mind .

Iv narrowed the problem down and think it's a switching problem ? checked all the voltages and caps ..the dreaded tants and 14 volts as the norm on the mobo , so tants seems ok ..im thinking Q903 and Q 904

Anyway everything works on it , all functions , and full output , just a quite hiss on receive , it still a quiet hiss when I tx ! The hiss is heard with the volume and rf gain full up and is certainly not as loud as it should go under normal circumstances but I'm hearing same hiss when keyed up ! 110 watts out .

Just no signals to be heard on any band . Scratches head ....any ideas ?

Best 73 .


Thu Oct 15, 2020 1:06 am
Profile Send private message
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.