It is currently Thu Nov 26, 2020 2:51 pm

Click the link below to visit the site sponsor

The Ham Radio Shop




Post new topic Reply to topic  [ 1 post ] 
 FTM-400XDE 
Contributor 2019
User avatar

Joined: Sat Jan 19, 2013 12:30 pm
Posts: 992
Location: Manchester
Feedback: 15 (100%)
Reply with quote
Post FTM-400XDE
Getting angry with Yaesu now, after years of them being fine, at least the ones I purchased.

However.... The FTM 400 seems to be their Ford Edsel. My FTM-400XDE which is supposed to be the 'fixed' model is now displaying failing FET output symptoms.
The repeater that I am keeper for Yaesu DR-1X is basically two FTM-400s in a box is a thermal nightmare and only works properly in winter!
People need to know this stuff, I feel.

Does anyone know a source of the dual fet block that is used as a PA? Or is it a Yaesu only job

thanks, Peter.

_________________
G4WLI (G8IKW) Peter
Education officer, West Manchester radio Club http://www.wmrc.co.uk/


Thu Nov 19, 2020 9:21 pm
Profile Send private message WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.